Millisecond Forums

Error message: InquisitControl.RunScriptFile is not a function

By katha - 7/14/2013

Hi everybody,

I uploaded a web experiment (which runs on my computer), but when I click the "Start" button on the launch side, there is an error message saying: "InquisitControl.RunScriptFile is not a function". I tried it on different computers, and in different launch modes, but it will either show the same message or hide the Start button. Any ideas what went wrong?

Thanks for your suggestions!


By Dave - 7/14/2013

Please provide the following info:

- Operating system and version

- Inquisit version used

- Browser version used

- Link to the experiment's launch page


By katha - 7/14/2013

- Windows 7 Version 6.1

- Inquisit

- Mozilla 22.0


By seandr - 7/15/2013

Thanks, Katha, I've just published an update to the launch page which will hopefully fix this. There was a change/bug in Firefox 22 that caused plugins not to be loaded if they had certain attributes. The new page has a workaround that should allow the plugin to load as normal.

Give it a try (before to Refresh the launch page in your browser) and let me know if the problem persists.


By katha - 7/15/2013

Hi Sean

Thanks for your help! Indeed, the plugin is now starting to load. But now it won't load the pics that it needs to run. I've uploaded a different script and all pics again, just to be sure - it runs locally but not online. Do you think it has to do with the same bug?

Here's the new link, if you want to try:

Thanks, Katha

By Dave - 7/15/2013

For some reason, those picture files have *not* been uploaded to the server / aren't available. You can easily see this by pasting the links given on the error page in your browser's address bar:

Unable to load the picture
Verify that the file exists and is of a supported format.
/items: Unable to load the picture
Verify that the file exists and is of a supported format.
/items: Unable to load the picture
Verify that the file exists and is of a supported format.

I suggest you take the script down, double-check all file names and re-upload.

By jbuczny - 12/4/2014


In my case the problem was the same. I waited ten minutes and refreshed browser then hit the link again - the problem vanished. I assume that it might have been caused by a lack of files transfers between server and computer since names all files like .jpg or .wav (and its' names) were alright (script worked on my desktop computer).

By psyclaw - 2/4/2016


From everything I've read, this issue was resolved 2 years ago, but unfortunately we are getting the same error (InquisitControl.RunScriptFile is not a function) with a person using Firefox.  He is using Firefox 44 with Windows 7 Enterprise Service Pack 1 and we have Inquisit 4 Web.  The link to our study is:

Any guidance would be greatly appreciated!

Thank you.