Millisecond Forums

Joystick support

By ddd3 - 4/2/2004

I have tried many different things but I cannot Inquisit to accept joystick input in Windows XP. I've tried gameport and USB joytsticks and neither work. The joysticks appear to work fine under the Windows control panel and DirectX Diagnose (dxdiag).


By Admin - 4/6/2004

What specific joystick models have your tried? We've done most of our testing with the SideWinder. If you are willing to mail us a joystick, we'll figure out why this it's not working, fix it if possible, and mail it back to you.

By ddd3 - 4/7/2004

I've tried a Gravis Gamepad Pro (USB), a generic gameport gamepad, a Gravis Eliminator Aftershock (USB), and an Xbox controller with a USB adapter and DirectX compatible driver for Windows XP. Inquisit 1.33 never seems to detect any joystick (an error pops up saying that no joystick was detected). Inquisit 2.0 detected at least the Gravis Gamepad Pro but it never works (i.e., Inquisit does not respond to it).

I'd rather try a couple other approaches before shipping you a joystick but I'd be happy to do that if it came down to it and if I could get the joystick back.

Here is a script I just tried out:

{text text_stim}
/ erase = true(0, 0, 0)
/ halign = center
/ hjustify = center
/ numitems = 6
/ items = ("string1", "string2", "string3", "string4", "string5", "string6")
/ position = (50, 50)
/ select = noreplace
/ txbgcolor = (0, 0, 0)
/ txcolor = (255, 255, 255)
/ valign =center
/ vjustify = center

{trial text_trial}

/ inputdevice = joystick

/ validresponse = (left,right,button1)

/ pretrialpause = 0
/ frames = [1=text_stim]
/ posttrialpause = 0
/ responsemode = free


{block main}
/screencolor = (0, 0, 0)
/trials = [1-6 = text_trial]



/ blocks = [1 = main]

BTW, I had to use {}'s beacuse the correct symbols made the form crash, as well as the keywords code and /code in brackets.