Millisecond Forums

Errors: "File not found," crashes, and technical limitations?

By pedrojose221 - 10/8/2013

The thread title may seem dramatic, but allow me to explain:

I am running the AOSPAN task on Inquisit Web 4 using the script provided by millisecond. I have been able to collect data from this task in the past 4 weeks, without the following error's that I will describe. I am wondering if anyone has experience dealing with the following errors or may know how to fix them.

The first is the following error that occurred when the participant attempted to download the Inquisit plug-in, but failed:

The second error has resulted in Inquisit crashing during the task. The occurrence is described so as the participant is completing the trial portion of the task in which practicing of the task takes place, when suddenly inquisit freezes to the point that a force close was necessary.

The second occurrence of this error was described in a way that the error message "File not found" was given about half-way through the task, resulting in termination and loss of data.

The third and final impedance seems to be more of technical limitations. A few participants mentioned that they could not complete the task because they could not download the Inquisit plug-in for their MAC device. I'm assuming it is incompatible with the OS..?

I should mention that 2/3 of the responses were successful in that aprticipants were able to complete the Inquisit task. If anyone has any insight as to how to prevent these errors it is well appreciated. Also, if I can get more information that will clarify the problem please let me know.



By Dave - 10/8/2013

#1: The first error indicates that the respective person's internet connection broke down (or had other issues) when trying to fetch the script.

#2: It is impossible to say anything useful about a single instance of random freezing. If you have further details about this, please share them. I can say with certainty, though, that receiving a "File not found" message half-way through is not something that can happen. There must be some mix-up / misunderstanding re. that report.

#3: Inquisit 4 is compatible with OSX (10.5.8 and above, I believe) running on Intel Macs. What problems exactly those participants were having, again unfortunately, is impossible to tell without further details (OS version, browser used, launch method chosen).

By pedrojose221 - 10/8/2013

Thanks for your prompt response Dave.

I understand the first error. The second, who knows, it could be that the participants decided not to finish the study and made up an error excuse to receive payment for their partial participation. At least that's my guess, given the zero percent chance you mentioned that the "File not found" error could occur half-way through the task.

As to the third, it seems the OSX version was outdated (4.x.x), so that clears that one up as well. 

There is one more error involving a failed installation of the plugin I received the following details from a participant:

"Here was the error notice I got for the second portion which required download of Inquisit. It would not install. It said 'Install Failed' 'The following install step failed: run postupgrade script for inquisit. Contact the softare manufacturer for assistance.' That is why I couldn't complete the second portion. I tried all the troubleshooting available on the site and nothing worked."

Any insight is appreciated.

By pedrojose221 - 10/8/2013


When asked to clarify the occurrence of Inquisit crashing, the participant said the following:

"When I clicked to answer one of the problems, it just flashed a balnk white screenthat said something like 'file not found.' I think there was more but it flashed too quickly to read. Then, that window closed completely and I was left looking at the original window where I began (the one with the Inquisit logo and info) except now the Start button that had been there to open the new window for the Inquisit task was no longer there. Since there was nothing there to click now, I tried reloading the page in the browser to try to start the Inquisit task over, but that didn't work and I just got a message that thanked me for taking your survey."

Hopefully this helps in troubleshooting the problem. Thanks again. 

By Dave - 10/8/2013

Thanks for the additional information. I have no spontaneous ideas re. both issues detailed -- we have not heard similar reports, as far as I am aware. I will let you know if I learn otherwise. I'm still puzzled re. the "File not found" problem midway through the script: Given that (a) Inquisit fetches all necessary files before ever running the script (i.e., any missing file errors should occur at startup, virtually never at runtime) and (b) the AOSPAN script doesn't even have any external file dependencies (no pictures etc., the script file alone is enough to run the task), I am struggling to form any plausible hypothesis about this. If it were some general issue, though, I would expect several similar reports.