error in running batched scripts


Author
Message
pkiss
pkiss
Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)
Group: Forum Members
Posts: 6, Visits: 10
Please help me solving a recurring technical problem.

We have a single user inquisit3 that runs batched scripts strangely under windows xp:  a shorter batch command runs safely, a longer one gets stuck in the middle (when opening the 3rd script) by a memory read error. All individual scripts run with no problem on xp and all batches are executed smoothly under win8.

The shorter batch file:
<batch>
/ subjects = (1 of 4)
/ groupassignment = random
/ file = "human.exp"
/ file = "IAT_pozitiv.exp"
/ file = "IAT_negativ.exp"
/ file = "IAT_preferencia.exp"
</batch>

<batch>
/ subjects = (2 of 4)
/ groupassignment = random
/ file = "human.exp"
/ file = "IAT_negativ.exp"
/ file = "IAT_pozitiv.exp"
/ file = "IAT_preferencia.exp"
</batch>

<batch>
/ subjects = (3 of 4)
/ groupassignment = random
/ file = "dehuman.exp"
/ file = "IAT_pozitiv.exp"
/ file = "IAT_negativ.exp"
/ file = "IAT_preferencia.exp"
</batch>

<batch>
/ subjects = (4 of 4)
/ groupassignment = random
/ file = "dehuman.exp"
/ file = "IAT_negativ.exp"
/ file = "IAT_pozitiv.exp"
/ file = "IAT_preferencia.exp"
</batch>

The longer batch file:
<batch>
/ subjects = (1 of 5)
/ groupassignment = random
/ file = "bevezetes.exp"
/ file = "IAT_ideo.exp"
/ file = "orban_neg.exp"
/ file = "partident.exp"
/ file = "IAT_partident.exp"
/ file = "IAT_orbgyurcs.exp"
/ file = "vege.exp"
</batch>

<batch>
/ subjects = (2 of 5)
/ groupassignment = random
/ file = "bevezetes.exp"
/ file = "IAT_ideo.exp"
/ file = "orban_poz.exp"
/ file = "partident.exp"
/ file = "IAT_partident.exp"
/ file = "IAT_orbgyurcs.exp"
/ file = "vege.exp"
</batch>

<batch>
/ subjects = (3 of 5)
/ groupassignment = random
/ file = "bevezetes.exp"
/ file = "IAT_ideo.exp"
/ file = "gyurcsany_neg.exp"
/ file = "partident.exp"
/ file = "IAT_partident.exp"
/ file = "IAT_orbgyurcs.exp"
/ file = "vege.exp"
</batch>

<batch>
/ subjects = (4 of 5)
/ groupassignment = random
/ file = "bevezetes.exp"
/ file = "IAT_ideo.exp"
/ file = "gyurcsany_poz.exp"
/ file = "partident.exp"
/ file = "IAT_partident.exp"
/ file = "IAT_orbgyurcs.exp"
/ file = "vege.exp"
</batch>


<batch>
/ subjects = (5 of 5)
/ groupassignment = random
/ file = "bevezetes.exp"
/ file = "IAT_ideo.exp"
/ file = "kontroll.exp"
/ file = "partident.exp"
/ file = "IAT_partident.exp"
/ file = "IAT_orbgyurcs.exp"
/ file = "vege.exp"
</batch>

Thank you for any hints!
Paszkal



Dave
Dave
Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)
Group: Administrators
Posts: 12K, Visits: 100K
Unfortunately this will be impossible to answer without

- details of the error messages from the system logs,

- technical (hard-, software) details on the affected system, and

- the actual scripts and stimuli.

If I were to hazard a guess, though, I'd say the machine in question has an issue w/ its RAM (either a physical defect or just not enough available to handle the longer <batch>es' overhead).

pkiss
pkiss
Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)
Group: Forum Members
Posts: 6, Visits: 10
We tried it in two different computers both computers had 1GB ram, Intel Celeron 2.XX Mhz processor. It is strange that they got stuck at the same position with the same error message.

I know that it is impossible to give a specific advice from a distance but is this specification sufficient for this batch to run in general? Do a batch command need much more RAM or speed to run?

Thanks a lot,

P.



Dave
Dave
Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)
Group: Administrators
Posts: 12K, Visits: 100K
While those specs should in general be sufficient, it also depends on what you're actually doing in your scripts. I.e., if you try to display massive amounts of pictures or videos, 1GB of RAM can be too low.

> It is strange that they got stuck at the same position with the same error message.

That is indeed interesting and may provide a clue. So what is that position / what was supposed to happen there?

pkiss
pkiss
Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)
Group: Forum Members
Posts: 6, Visits: 10
It occurs between two survey scripts. First is a one page text and another page of survey questions to be chosen from 5 alternatives (random experimental conditions). Second is a series of survey questions. It stops before starting this latter.

I managed to copy the application log reporting the error (it is partly Hungarian, but might be understood still):

Hibás alkalmazás: inquisit.exe, verzió: 3.0.6.0, hibásmodul: inquisit.exe, verzió: 3.0.6.0, memóriacím: 0x0012d18f.

 További tájékoztatást a súgóban talál a következő helyen: http://go.microsoft.com/fwlink/events.asp.

Adat:

0000: 41 70 70 6c 69 63 61 74   Applicat
0008: 69 6f 6e 20 46 61 69 6c   ion Fail
0010: 75 72 65 20 20 69 6e 71   ure  inq
0018: 75 69 73 69 74 2e 65 78   uisit.ex
0020: 65 20 33 2e 30 2e 36 2e   e 3.0.6.
0028: 30 20 69 6e 20 69 6e 71   0 in inq
0030: 75 69 73 69 74 2e 65 78   uisit.ex
0038: 65 20 33 2e 30 2e 36 2e   e 3.0.6.
0040: 30 20 61 74 20 6f 66 66   0 at off
0048: 73 65 74 20 30 30 31 32   set 0012
0050: 64 31 38 66 0d 0a         d18f.. 

Before these two scripts there is a picture IAT that runs properly.
No videos.


Dave
Dave
Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)
Group: Administrators
Posts: 12K, Visits: 100K
What happens when you move the latter script to a different position in the batch? If the error "moves with it", it would strongly suggest there's something wrong with that particular script.

pkiss
pkiss
Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)
Group: Forum Members
Posts: 6, Visits: 10
Exchanged scripts as you suggested. Now the former short survey is followed by an IAT. And the error did not move...it disappeared. :)

If I tried again the original script and the error reappeared in the same position.



pkiss
pkiss
Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)
Group: Forum Members
Posts: 6, Visits: 10
original *order of* scripts

Dave
Dave
Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)
Group: Administrators
Posts: 12K, Visits: 100K
Interesting -- must be some sort of weird interaction at work here. Not sure what the exact cause may be, though.

pkiss
pkiss
Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)Expert (1.1K reputation)
Group: Forum Members
Posts: 6, Visits: 10
It is strange, I agree. But at least we have a B-plan now if we  still want to use it under xp.

Thank you for your help,

Paszkál
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Explore
Messages
Mentions
Search