help plz, bg stimulus image covering caption of radiobutton question


Author
Message
ardelano
ardelano
Expert (1.3K reputation)Expert (1.3K reputation)Expert (1.3K reputation)Expert (1.3K reputation)Expert (1.3K reputation)Expert (1.3K reputation)Expert (1.3K reputation)Expert (1.3K reputation)Expert (1.3K reputation)
Group: Forum Members
Posts: 5, Visits: 25
Hi everyone. I have a small problem with my experiment and I'm hoping someone can help me figure this out.

In my survey the background stimulus covers the entire window, i.e. the question has to appear in front of the bg stimulus in order to be visible.
When I run the experiment, the radio button options are visible. However the caption of my radiobutton element is being covered by the bg stimulus when I run the experiment.
I can tell the caption is hidden underneath the image because when i run the experiment and move back and forth between the pages of the survey the caption appears for a fraction of a second before dissapearing behind the image. 
Does anyone have any idea how I can force the caption to stay visible?

Here is my code:

<picture pictureconditioningbase>
/ items = itemconditioningbase
</picture>

<item itemconditioningbase>
/ 1 = "conditioningbase.jpg"
</item>

<radiobuttons rbcond1>
/ position = (240px, 490px)
/ caption = "Which of these candidates do you think would be best for the position of: MINISTER OF DEFENSE" 
/ options = (
    "Candidate W", 
    "Candidate X", 
    "Candidate Y", 
    "Candidate Z" )
/ optionvalues = ("W", "X", "Y", "Z")
/ required = true
</radiobuttons>

<surveypage cond1>
/ fontstyle = ("Arial", -14, false, false, false, false, 5, 0)
/ questions = [1=rbcond1]
/ stimulusframes = [ 1 = pictureconditioningbase ]
</surveypage>

<survey conditioning>
/ recorddata = true
/ pages = [1=cond1]
/ responsefontstyle = ("Arial", -16, false, false, false, false, 5, 0)
/ itemfontstyle = ("Arial", -13, false, false, false, false, 5, 0)
/ itemspacing = 10%
/ showpagenumbers = false
/ finishlabel = "Continue"
</survey>

<expt>
/ blocks = [1=conditioning]
</expt>

Dave
Dave
Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)
Group: Administrators
Posts: 12K, Visits: 83K
Use a <text> element to display the question text instead of the <radiotbuttons> /caption:

<text question>
/ items = ("Which of these candidates do you think would be best for the position of: MINISTER OF DEFENSE")
</text>

<radiobuttons rbcond1>
/ position = (240px, 490px)
/ options = (
    "Candidate W",
    "Candidate X",
    "Candidate Y",
    "Candidate Z" )
/ optionvalues = ("W", "X", "Y", "Z")
/ required = true
</radiobuttons>

<surveypage cond1>
/ fontstyle = ("Arial", -14, false, false, false, false, 5, 0)
/ questions = [1=rbcond1]
/ stimulusframes = [ 1 = pictureconditioningbase, question ]
</surveypage>

ardelano
ardelano
Expert (1.3K reputation)Expert (1.3K reputation)Expert (1.3K reputation)Expert (1.3K reputation)Expert (1.3K reputation)Expert (1.3K reputation)Expert (1.3K reputation)Expert (1.3K reputation)Expert (1.3K reputation)
Group: Forum Members
Posts: 5, Visits: 25
Thanks for your quick response, but I forgot to add an important point to my previous description of the problem.

The survey is set to force a response from the participant, so when the question is left unanswered and you press "next" it won't continue unless an answer is selected. So when my experiment runs and you dont set an answer the caption suddenly becomes visible in red font, in the place where the caption is supposed to be. For some reason this 'error' forces the caption forward...

So I dont think your suggested solution would work, because if the error caption appears it would appear on top of the text from the textbox. Or am i wrong?

Dave
Dave
Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)
Group: Administrators
Posts: 12K, Visits: 83K
> [...] if the error caption appears it would appear on top of the text from the textbox. Or am i wrong?
If there is no /caption, nothing can be forced in the foreground in case of a non-response. Try it for yourself.

ardelano
ardelano
Expert (1.3K reputation)Expert (1.3K reputation)Expert (1.3K reputation)Expert (1.3K reputation)Expert (1.3K reputation)Expert (1.3K reputation)Expert (1.3K reputation)Expert (1.3K reputation)Expert (1.3K reputation)
Group: Forum Members
Posts: 5, Visits: 25
Ok I tried your solution and once i changes the alignment setting of the text it worked. Thank you for your help.
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Explore
Messages
Mentions
Search