Cedrus response box support with Inquisit 4


Author
Message
KJantzen
KJantzen
Respected Member (386 reputation)Respected Member (386 reputation)Respected Member (386 reputation)Respected Member (386 reputation)Respected Member (386 reputation)Respected Member (386 reputation)Respected Member (386 reputation)Respected Member (386 reputation)Respected Member (386 reputation)
Group: Forum Members
Posts: 3, Visits: 6
I am using a cedrus response box 530 to collect responses and to trigger EEG equipment.  It is important that I only get a single ttl trigger for each button press but it seems that Inquisit is putting the response box into double pulse mode where I get a ttl trigger when the button is pushed and a second when the button is released.  Is there any way to control or alter this in Inquisit?
Dave
Dave
Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)
Group: Administrators
Posts: 12K, Visits: 101K
I am not aware of any way to alter an RB's accessory connector behavior directly from Inquisit -- at least not at present. However, if I am not totally mistaken, the accessory connector's behavior -- including pulse mode -- can be configured using Cedrus' "Xidon" tool:

http://www.cedrus.com/download/files/xidon_1p2.exe

Or are you suggesting that Inquisit *alters* the pad's configuration to double-pulsing?

KJantzen
KJantzen
Respected Member (386 reputation)Respected Member (386 reputation)Respected Member (386 reputation)Respected Member (386 reputation)Respected Member (386 reputation)Respected Member (386 reputation)Respected Member (386 reputation)Respected Member (386 reputation)Respected Member (386 reputation)
Group: Forum Members
Posts: 3, Visits: 6
Yes, it seems that Inquisit does alter the response pad to double pulsing.  I used in house matlab code to alter the mode of the response pad to single pulse mode.  After verifying this mode using in my EEG acquisition software I ran my inquisit code and when I responded to stimuli I found that the button box was once again in double pulse mode. 
Dave
Dave
Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)
Group: Administrators
Posts: 12K, Visits: 101K
Thanks for the clarification. Then all I can do for the time being is file a bug report so this gets fixed in the next release -- at the very least, Inquisit should not change the pad's configuration inadvertently.

Dave
Dave
Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)
Group: Administrators
Posts: 12K, Visits: 101K
One more question, if I may: Which Inquisit version have you been using? If it is not up-to-date ( v. 4.0.6.0 at the time of writing), could you please confirm the issue w/ the latest release? Thank you.

Erik
Erik
Partner Member (859 reputation)Partner Member (859 reputation)Partner Member (859 reputation)Partner Member (859 reputation)Partner Member (859 reputation)Partner Member (859 reputation)Partner Member (859 reputation)Partner Member (859 reputation)Partner Member (859 reputation)
Group: Moderators
Posts: 13, Visits: 199
Could you please provide me a copy of the script you're using?  

I know that Inquisit doesn't contain any code that would set it to double pulse mode (a13).  However, if a response box is used as a stimulus via the <xid> element  we do set the lines to General Purpose (a10), the direction to output (a4), and optionally set the pulse duration (ap).  I haven't confirmed, but we may also set that if you just have an <xid> element in the script, but that would be an easily fixable bug.

If you just have a single XID device used just as an input device (and you don't need to scan for a specific one or alter the pulse duration) you can just specify /inputdevice = xid in <defaults> and omit the <xid> element and Inquisit shouldn't touch those settings.

Thanks and Enjoy,
Erik



Developer at Millisecond Software, LLC.
seandr
seandr
Supreme Being (142K reputation)Supreme Being (142K reputation)Supreme Being (142K reputation)Supreme Being (142K reputation)Supreme Being (142K reputation)Supreme Being (142K reputation)Supreme Being (142K reputation)Supreme Being (142K reputation)Supreme Being (142K reputation)
Group: Administrators
Posts: 1.3K, Visits: 5.6K
FYI - I've just posted an updated version of Inquisit 4.0.6 that should fix this problem. You can download and install from our download page:
http://www.millisecond.com/download/
You'll have to uninstall your existing copy of 4.0.6 before you can install this one.
Give it a whirl and let us know if the problem persists.

Thanks,
Sean



KJantzen
KJantzen
Respected Member (386 reputation)Respected Member (386 reputation)Respected Member (386 reputation)Respected Member (386 reputation)Respected Member (386 reputation)Respected Member (386 reputation)Respected Member (386 reputation)Respected Member (386 reputation)Respected Member (386 reputation)
Group: Forum Members
Posts: 3, Visits: 6
Thanks for the responses and fixes.  I will give them a try.
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Explore
Messages
Mentions
Search