Unknown system error. File IQKey.cpp


Author
Message
dinghu
dinghu
Associate Member (154 reputation)Associate Member (154 reputation)Associate Member (154 reputation)Associate Member (154 reputation)Associate Member (154 reputation)Associate Member (154 reputation)Associate Member (154 reputation)Associate Member (154 reputation)Associate Member (154 reputation)
Group: Forum Members
Posts: 17, Visits: 47
Running my experiment, I am getting the following error: Unknown system error. Line 353, File IQKey.cpp
It doesn't seem to have caused any fatal malfunctions to the script, but I am not sure why it is happening. This error did not appear when I previously tested on my own, and it does not appear when validating my script, only as errors when running the program on Inquisit Web once the experiment went live. The code at line 353 is just this:

<picture mask>
/ items = maskitems
/ select = noreplace
</picture>

Line 353 is the last line. From searching through the forum, I found someone else had a related issue, but theirs was an incorrect assignment of a /prevkey (0), which I have also noticed in my script. The only thing is, that error is nowhere near line 353, and that script is not interacting with the picture mask area. Can I simply delete the /prevkey (0) line? I do not actually need participants to be able to go back, so I am not sure why I had this typed up in the first place.


dinghu
dinghu
Associate Member (154 reputation)Associate Member (154 reputation)Associate Member (154 reputation)Associate Member (154 reputation)Associate Member (154 reputation)Associate Member (154 reputation)Associate Member (154 reputation)Associate Member (154 reputation)Associate Member (154 reputation)
Group: Forum Members
Posts: 17, Visits: 47
dinghu - 5/9/2024
Running my experiment, I am getting the following error: Unknown system error. Line 353, File IQKey.cpp
It doesn't seem to have caused any fatal malfunctions to the script, but I am not sure why it is happening. This error did not appear when I previously tested on my own, and it does not appear when validating my script, only as errors when running the program on Inquisit Web once the experiment went live. The code at line 353 is just this:

<picture mask>
/ items = maskitems
/ select = noreplace
</picture>

Line 353 is the last line. From searching through the forum, I found someone else had a related issue, but theirs was an incorrect assignment of a /prevkey (0), which I have also noticed in my script. The only thing is, that error is nowhere near line 353, and that script is not interacting with the picture mask area. Can I simply delete the /prevkey (0) line? I do not actually need participants to be able to go back, so I am not sure why I had this typed up in the first place.


I re-read the forum thread I found and realized that the answer was right there already. My bad, I overlooked that my question was already answered. Yes, deleting the /prevkey (0) line will fix the issue. And it did. A few more trials ran properly and threw up no errors.
Dave
Dave
Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)
Group: Administrators
Posts: 12K, Visits: 100K
dinghu - 5/9/2024
dinghu - 5/9/2024
Running my experiment, I am getting the following error: Unknown system error. Line 353, File IQKey.cpp
It doesn't seem to have caused any fatal malfunctions to the script, but I am not sure why it is happening. This error did not appear when I previously tested on my own, and it does not appear when validating my script, only as errors when running the program on Inquisit Web once the experiment went live. The code at line 353 is just this:

<picture mask>
/ items = maskitems
/ select = noreplace
</picture>

Line 353 is the last line. From searching through the forum, I found someone else had a related issue, but theirs was an incorrect assignment of a /prevkey (0), which I have also noticed in my script. The only thing is, that error is nowhere near line 353, and that script is not interacting with the picture mask area. Can I simply delete the /prevkey (0) line? I do not actually need participants to be able to go back, so I am not sure why I had this typed up in the first place.


I re-read the forum thread I found and realized that the answer was right there already. My bad, I overlooked that my question was already answered. Yes, deleting the /prevkey (0) line will fix the issue. And it did. A few more trials ran properly and threw up no errors.

To clarify, the line number does not refer to your script. It's the line number in the source code component of the Inquisit engine throwing the error. Here, IQKey.cpp, the C++ source code file of the engine component handling all things related to key(board) input. You obviously don't have access to the Inquisit source code, so this information is primarily useful for us as developers to track down bugs in the engine itself or get an idea about what type of mistake may exist in a script that elicits an error (here: an invalid definition of an input key).

Edited Last Month by Dave
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Explore
Messages
Mentions
Search