odd question... (concerning a rectangle with color (1,0,0))


Author
Message
m.hengstler
m.hengstler
Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)
Group: Forum Members
Posts: 7, Visits: 1

Hi all,


I've got a rather odd question. Could you please run the attached script, and see if it gives you an error?


The thing is that I have a trial which continuously updates the color red of a rectangle shape.


It always gives me an error, this error to be specific:


---
Unknown system error.
Line 760, File .\DirectDraw7.cpp
DirectX Error DDERR_SURFACEBUSY (0x887601AE): Access to this surface is being refused because the surface is already locked by another thread..
Line 644, File .\DirectDraw7.cpp
DirectX Error E_ACCESSDENIED (0x80070005): Access is denied.
Line 160, File .\DirInput.cpp
---


If I change the shape of the dot into a circle, this problem disappears.


Can anyone replicate this problem, and what might be causing it?



Thanks in advance,


Maikel


Attachments
btr.exp (763 views, 889 bytes)
m.hengstler
m.hengstler
Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)
Group: Forum Members
Posts: 7, Visits: 1

Attached is the data file. What I notice is that there is an abnormal large stimulusonset at the point where the color of the shape is exactly (1,0,0)...


Attachments
btr.dat (791 views, 788 bytes)
Dave
Dave
Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)
Group: Administrators
Posts: 12K, Visits: 82K

Apparently it's a bug in Inquisit's handling of the RED color channel for rectangle <shape> elements. The problem does not occur for the other two color channels (try it for yourself). Anyway, I'll file a bug report for this. For the time being, you can use <text> elements instead of rectangular <shape>s to avoid the issue:


<text black>
/ items = (" ")
/ txbgcolor = (black)
/ position = (50%,50%)
/ size = (100%,100%)
/ erase = false
</text>

<text dot>
/ items = (" ")
/ txbgcolor = (black)
/ position = (50%,50%)
/ size = (100px,100px)
/ erase = false
</text>

<trial black_blacktored>
/ ontrialbegin = [text.dot.textbgcolor = black]
/ trialduration = 0
/ branch = [trial.black_blacktored2]
</trial>

<trial black_blacktored2>
/ stimulustimes = [0=black,dot]
/ ontrialend = [text.dot.textbgcolorred = min(text.dot.textbgcolorred + 1, 255)]
/ trialduration = 100
/ validresponse = (57)
/ branch = [if (trial.black_blacktored2.response == "57") trial.done]
/ branch = [trial.black_blacktored2]
</trial>

<trial done>
/ trialduration = 0
</trial>

<block test>
/ trials = [1 = black_blacktored]
</block>


Regards,


~Dave


m.hengstler
m.hengstler
Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)Esteemed Member (1.8K reputation)
Group: Forum Members
Posts: 7, Visits: 1

Thanks for your reply Dave. I indeed also noticed that the problem does not occur when I change it to another color (ie. green or blue).


Also thanks for the slight modifications in the script. :)



Best,


Maikel


GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Explore
Messages
Mentions
Search