slider response in summary data


Author
Message
bmatt
bmatt
Partner Member (885 reputation)Partner Member (885 reputation)Partner Member (885 reputation)Partner Member (885 reputation)Partner Member (885 reputation)Partner Member (885 reputation)Partner Member (885 reputation)Partner Member (885 reputation)Partner Member (885 reputation)
Group: Forum Members
Posts: 7, Visits: 57
I'm having trouble getting responses to slider items showing up in summary data.  I have created separate sliders for specific items (each on their own survey page), like so...

<survey item_ratings>
/ pages = [1 = rate_item1]
</survey>

<surveypage rate_item1>
/ caption = "Please rate how positive or negative the following items are:"
/ questions = [1=item1]
/ finishlabel = "Next"
</surveypage>

<slider item1>
/ caption = "Item 1"
/ labels = ("very negative", "very positive")
/ range = (0, 60)
/ increment = 1
/ showticks = false
/ showtooltips = false
/ required = true
</slider>

Then, in summary data, I request responses to this item, like so...

<summarydata>
/ columns = [slider.item1.response]
</summarydata>

I am running the Monkey to ensure my summarydata is recording properly.  I am getting values for all of my other columns, such as likert responses, but the slider.item1.response column remains blank.  Any sense on what I'm doing wrong here? 



Dave
Dave
Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)Supreme Being (1M reputation)
Group: Administrators
Posts: 12K, Visits: 100K
You're not doing anything wrong. Most likely your Inquisit installation is outdated -- <summarydata> could not be used together with <survey> elements initially. Make sure you download & install the latest version (4.0.8.0) and it should work just fine.

EDIT: I missed the fact that you are specifically using the monkey, not testing manually. I can reproduce the monkey-case (it does not provide a slider-response -- neither in the summary nor in the raw data file). It works fine when you run the script manually, though. This only happens when /required is set to 'true' in the <slider>. To generate test data, you can temporarily set it to false and do something along the lines of:

<slider item1>
/ caption = "Item 1"
/ labels = ("very negative", "very positive")
/ range = (0, 60)
/ increment = 1
/ showticks = false
/ showtooltips = false
/ required = false
/ monkeyresponse = [round(rand(0,60));]

</slider>


Edited 9 Years Ago by Dave
bmatt
bmatt
Partner Member (885 reputation)Partner Member (885 reputation)Partner Member (885 reputation)Partner Member (885 reputation)Partner Member (885 reputation)Partner Member (885 reputation)Partner Member (885 reputation)Partner Member (885 reputation)Partner Member (885 reputation)
Group: Forum Members
Posts: 7, Visits: 57
Ah, okay, thanks!  
GO

Merge Selected

Merge into selected topic...



Merge into merge target...



Merge into a specific topic ID...




Reading This Topic

Explore
Messages
Mentions
Search